Viewing 3 reply threads
  • Author
    Posts
    • #6006
      Chris
      Member
      • Topics: 2
      • Replies: 5
      @clarke078
      Norfolk
      Gt125r

      Hi guys, new here so excuse me if it’s obvious or has been spoken about before.

      having charging issues with my Gt125r (carb)so gone to check the stator/magneto, whatever you wanna call it and dropped all my oil.

      now the cover has a gasket suggesting it should hold fluid but this is a new one for me so could anyone confirm that for me please?

      many thanks,

      Chris

    • #6007
      Simon
      Member
      • Topics: 1
      • Replies: 258
      @syco
      Kent
      Gt250 f1

      Yep the stator runs in the oil, the first check on the stator you just need a multimeter & unplug the connector with the 3 yellow wires that connects to the rectify then touch 1 to another cover all the combos 1-2, 1-3, 2-3 if its good the reading should look like 0.3, 0.2, 0.1 something like that if it’s 1 or above the stator is toast.

    • #6008
      Chris
      Member
      • Topics: 2
      • Replies: 5
      @clarke078
      Norfolk
      Gt125r

      Ok thanks, I’ve ordered a new one now from hyosung parts uk and payed for 3-4 days delivery (Β£26) still in Korea though πŸ™„

    • #6010
      Simon
      Member
      • Topics: 1
      • Replies: 258
      @syco
      Kent
      Gt250 f1

      Whatever you do make sure that you check the rectify/regulator as it’s normally the gremlin that causes the stator to fry

Viewing 3 reply threads
  • You must be logged in to reply to this topic.