Topic Tag

no spark

May 17, 2022

No spark – GT250 Carby


I’ve got a carb’d ‘parts’ bike that came with a running race bike I bought a year ago. The carb’d bike was a race bike but blew the rear cylinder. It was completely stripped of all parts (except for the loom) and I am now trying to put it back together without knowing how it came apart. Hyos are fairly new to me but I have a manual but I’m not sure exactly what year carb’d bike I have, so I’m not sure if I have the correct manual – it has wiring diagram for efi fuel pump but then has carb info (?).

Anyway, heres the situation:

  • I’ve got the engine, carb, fuel and vent hoses all connected.
  • I’ve got a good battery hooked up.
  • The neutral light on the dash is on, turns off when I put it in gear. The drive sproket spins freely in neutral.
  • Side stand switch wires are joined – found them like this
  • Clutch switch wires were not joined, but wiring diagram shows them as joined for ‘Run’. I’ve joined them – makes no difference to my spark issue below.
  • Spark plugs cleaned up and gaps checked – they were fine
  • Main fuse is fine – I only seem to have one that I can see. Are any others needed to run the bike? Its a race bike – no lights, indicators etc.

I’ve turned the key on, dash lights up, switched kill switch to ‘run’, hit the starter, bike cranks over strongly, choke on, but it doesn’t fire. Try a few times, battery and starter are going strong non stop but still not firing. Fuel is definately getting to the carbs as I can smell it in the exhaust and my bottle is draining. Pull front spark plug out and plug it into the spark plug lead, hold against cylinder and try starter again – no spark. Try rear spark plug – no spark. Take spark plug out of plug lead and put small file into spark lead and hold near cylinder – no spark on either front or rear.

I’ve taken the coils off and sanded the earthing points on the frame to bare metal. I did the same for the battery earth. I’ve cleaned out the primary connector wires and scrubbed up the tab that the wires connect to on the coils – still no spark

Testing the coils I get:

Front – Primary: 0.1 ohm

Front – Secondary: 14.7 Kohm

Rear – Primary: 0.1 ohm

Rear – Secondary: 16.48 Kohm

I bought an auto ranging multimeter for this project but I didn’t realise it didn’t read to 2 decimal places. Looking at the manual my range should be 0.19-0.24 ohm and 5.4-6.6 Kohm – if I have the correct manual. Can anyone confirm if my manual is correct?

Testing check:

Front – coil only – 6.13 Kohm, lead only – 0.0 ohm, plug cap – 8.67 Kohm = 14.8

Rear – coil only – 6.19 Kohm, lead ony – 0.0 ohm, plug cap – 10.39 Kohm = 16.58

In my mind, the coils are my issue with resistance that is too high. My only issue is I don’t know if I have the correct ranges from the manual. I’ve pulled the CDI and regulator rectifier out to check with the multimeter but the diagram I have for the CDI has 2x 4 pin connectors. Mine is 2x 4 pin connectors and 1x 2 pin connector (10x pins total). I thought I’d test the coils off my efi bike so I took that apart only to discover they use different coils! I don’t think the RR is my issue as the bike should still idle without it kicking in .

Any ideas??



Jul 24, 2021

2010 GV650 help indetify wires


I have a 2010 GV650 efi that i took apart to paint and now I can’t find / remember where one of the plugs connects.

The plug is a 2 wire: Black with Yellow tracer and White with Blue Tracer and it is located at the front end of the harness ( by the headlight)

I would like to know what was connected to those wires.

Thank you

**PS: the bike does not start now ( NO SPARK) and I think it may be related to the missing connection.

I checked the coils, rectifier, pick up coil..everything seems to be within manual specs.

I replaced the pickup (pulse) coil because I got  F1 code  C12, but that did not help, still have the code and no spark with the new pickup coil installed)

I have installed 3 extra grounds ( engine frame- frame battery- engine battery)

I hope my ECM is good ..

Thank you